Are you lost or something?! >:)


2014/08/08 AMD_6xGPU_Code_43

On Windows with 6 or more GPUs some will show "Windows has stopped this device because it has reported problems. (Code 43)" status in Device Manager and won't work.

Turns out AMD driver configuration is causing "Code 43".

2014/07/16 AMD_6xGPU_mod_Application

6xGPU_mod will modify AMD driver configuration stored in system registry to enable support for 6 and more GPUs fixing "Code 43" error.

2014/03/7 Windows_Server_2003_SMTP_TLS_Receive_Problem

Issue

Windows Server 2003 SMTP service(or Exchange Server 2003/2007) does not receive some emails.

Solution(not found)

KB957047 fixes SMTP, KB938857 - Exchange IMAP and POP3, KB948963 adds AES support and both 3DES and AES start to work properly with SMTP service and Exchange server.

It may be necessary to install KB976323 after SMTP hotfix.

What's going on

SMTP service logs show multiple repeating entries with following pattern:

EHLO .. STARTTLS .. STARTTLS .. EHLO .. MAIL .. QUIT

#Fields: date time c-ip cs-username s-sitename s-computername s-ip s-port cs-method cs-uri-stem cs-uri-query sc-status sc-win32-status sc-bytes cs-bytes time-taken cs-version cs-host cs(User-Agent) cs(Cookie) cs(Referer)

YYYY-MM-dd hh:mm:ss [c-ip] [cs-username] [s-sitename] [s-computername] [s-ip] 0 EHLO - +[cs-username] 250 0 235 16 0 SMTP - - - -

YYYY-MM-dd hh:mm:ss [c-ip] [cs-username] [s-sitename] [s-computername] [s-ip] 0 STARTTLS - - 220 0 0 8 0 SMTP - - - -

YYYY-MM-dd hh:mm:ss [c-ip] [cs-username] [s-sitename] [s-computername] [s-ip] 0 STARTTLS - - 220 0 29 8 0 SMTP - - - -

YYYY-MM-dd hh:mm:ss [c-ip] [cs-username] [s-sitename] [s-computername] [s-ip] 0 EHLO - +[cs-username] 250 0 267 16 0 SMTP - - - -

YYYY-MM-dd hh:mm:ss [c-ip] [cs-username] [s-sitename] [s-computername] [s-ip] 0 MAIL - +FROM:<[email@email.com]> 250 0 0 105 0 SMTP - - - -

YYYY-MM-dd hh:mm:ss [c-ip] [cs-username] [s-sitename] [s-computername] [s-ip] 0 QUIT - [cs-username] 240 1016 0 105 0 SMTP - - - -

sc-status 240 = SMTP Status: 240 - 2.4.0 = Success with "Other or undefined network or routing status"

sc-win32-status 1016 = Win32 error: ERROR_REGISTRY_IO_FAILED 1016 (0x3F8) - "An I/O operation initiated by the registry failed unrecoverably. The registry could not read in, or write out, or flush, one of the files that contain the system's image of the registry." As reported by net helpmsg 1016.

Looks like reported sc-win32-status is meaningless, because it is not persistent - 1016, 1031, 1062, 1047, 1235, 1360, 1563, 1578.

 

Regtrace logs

simssl.cpp CEncryptCtx::SealMessage InBuf: 0x030AF015, OutBuf: 0x030AF010, in: 104, max: 104, out: 137

simssl.cpp CEncryptCtx::SealMessage SealMessage returned: 0, 0x00000000

conn.cxx CLIENT_CONNECTION::WriteFile Error send() - 0x2746

conn.cxx CLIENT_CONNECTION::WriteFile Bytes sent = 0, # of Sleep = 0, Next sleeptime = 5

smtpcli.cxx SMTP_CONNECTION::SendSmtpRespon cWriteFile failed with error 10054

WSAECONNRESET 10054 (0x2746) - "An existing connection was forcibly closed by the remote host."

Most likely that happens between SMTP MAIL and QUIT. Probably SMTP server sends ack for MAIL command and fails.

 

If SSL/TLS certificate is removed from SMTP emails can be received. So the issue now becomes - SMTP cannot receive some emails using TLS/SSL.

"Some" - because emails are received from Google using TLS/SSL fine.

 

SCHANNEL log shows that google is using following TLS/SSL negotiated cipher:

An SSL server handshake completed successfully. The negotiated cryptographic parameters are as follows.

Protocol: TLS (SSL 3.1)

Cipher: RC4

Cipher strength: 128

MAC: MD5

Exchange: RSA

Exchange strength: 4096

And for session with not received email -

An SSL server handshake completed successfully. The negotiated cryptographic parameters are as follows.

Protocol: TLS (SSL 3.1)

Cipher: Triple-DES

Cipher strength: 168

MAC: SHA

Exchange: RSA

Exchange strength: 4096

 

Quick search reveals that apparently Windows or Schannel or SMTP or IIS has some issues with 3DES cipher:

And has some compatibility issues with OpenSSL:

And there is something wrong with ciphers string:

And s1 has exactly the same issue:

 

The Windows 2003 TLS stack (still used by a non-trivial number of Microsoft Exchange SMTP servers) only looks at the first 64 elements of the cipherlist. If neither RC4-SHA nor RC4-MD5 are among these, it sometimes chooses 3DES (for which it misimplements CBC padding) and fails during data transfer, or if that is suppressed or also too far down the list, just fails the handshake. re [TLS] Windows 2003 TLS 64 ciphersuite limit

 

To confirm all ciphers except 3DES were disabled using IISCrypto utility.

To get additional info TLS Receiver Test and Qualys SSL Labs - Projects - SSL Server Test online tests were used.

Also OpenSSL client was used to connect to Windows SMTP with following command openssl s_client -msg -debug -connect SMTP_SERVER:25 -starttls smtp

After enabling only 3DES Windows SMTP stopped receiving emails from google also, TLS Receiver Test also started to fail on Sndr OK step. But both Schannel logs and TLS Receiver Test showed cipher being negotiated correctly to 3DES. SSL Labs also showed 3DES as only available cipher.

OpenSSL client reported:

CONNECTED(00000708)

>>> TLS 1.0 Handshake [length 00cd], ClientHello

<<< TLS 1.0 Handshake [length 0051], ServerHello

<<< TLS 1.0 Handshake [length 0c95], Certificate

<<< TLS 1.0 Handshake [length 0004], ServerHelloDone

>>> TLS 1.0 Handshake [length 0106], ClientKeyExchange

>>> TLS 1.0 ChangeCipherSpec [length 0001]

>>> TLS 1.0 Handshake [length 0010], Finished

<<< TLS 1.0 ChangeCipherSpec [length 0001]

<<< TLS 1.0 Handshake [length 0010], Finished

New, TLSv1/SSLv3, Cipher is AES128-SHA

Server public key is 4096 bit

Secure Renegotiation IS supported

SSL-Session:

Protocol : TLSv1

Cipher : AES128-SHA

>>> TLS 1.0 Alert [length 0002], fatal protocol_version

02 46

To ensure that there were no protocol screw-ups both -tls1 and -ssl3 options were tried in OpenSSL client leading to the same result.

After re-enabling RC4, emails from google went through and TLS Receiver Test reported OK for all steps.

 

Further search revealed that Microsoft released KB948963 update which adds support for the TLS_RSA_WITH_AES_128_CBC_SHA AES128-SHA and the TLS_RSA_WITH_AES_256_CBC_SHA AES256-SHA AES cipher suites in Windows Server 2003.

After update installation and enabling only AES cipher the issue still persisted. Also there were issues removing the update.

 

2014/07/28 Update Windows_3DES_CBC_Issue

Did some more digging using WireShark and OpenSSL client.

Launched OpenSSL client with following command:

openssl s_client -tls1 -cipher 3DES -debug -connect smtp_server_name:25 -starttls smtp > logfile3.txt 2>&1

Then EHLO was sent and following was logged by OpenSSL client:

0000 - 0a f5 16 b3 45 65 dc 11-48 6a d0 e2 e7 b3 c5 71 ....Ee..Hj.....q

0010 - 1c 01 8a ef 49 ae 21 1f-2d 5c be c0 dc 9c 28 88 ....I.!.-\....(.

0020 - 97 f1 8e 80 94 a2 25 9c-f7 8c 35 b9 ec 5a a9 17 ......%...5..Z..

0030 - ae 5b b3 fe 04 13 f1 1a-96 f0 5a 4b f4 c9 70 21 .[........ZK..p!

0040 - 96 f7 38 fc dc 69 db 61-20 0b 0d 42 e8 79 85 28 ..8..i.a ..B.y.(

0050 - e0 6e 6c 89 e4 f5 88 18-a8 82 20 6b 0f c3 ae da .nl....... k....

0060 - ef f6 2b 4e df 47 c5 c2-72 5c 27 84 50 fe 22 96 ..+N.G..r\'.P.".

0070 - 28 61 35 0e ba 11 63 27-5a 25 52 0b 6f 35 3c 6b (a5...c'Z%R.o5<k

0080 - c3 3e 4f a5 25 19 ab 0d-2e a1 d9 51 94 d8 2d 7a .>O.%......Q..-z

0090 - c2 2b 07 f2 f8 78 60 a1-eb db fc a1 89 1c 99 bf .+...x`.........

00a0 - 75 36 23 b5 a1 d5 9e 80-ba 40 98 93 23 97 16 33 u6#......@..#..3

00b0 - be d6 c4 d2 9b c6 7e 78-54 2c 60 da dd 10 9e 6c ......~xT,`....l

00c0 - 8d e7 6e d7 44 ae 7e fe-64 6b df ac 51 89 6a 10 ..n.D.~.dk..Q.j.

00d0 - 39 66 04 46 01 30 62 c2-65 d7 6b 75 2a 3f 6e 53 9f.F.0b.e.ku*?nS

00e0 - fd 32 6c b1 75 1f 52 18-c9 de 8a 95 ec 93 32 18 .2l.u.R.......2.

00f0 - bf 7e 44 9e de dc 13 63-e7 7e 98 f1 a4 97 37 d2 .~D....c.~....7.

read from 0x70ce88 [0x5cd683] (5 bytes => 5 (0x5))

0000 - 65 20 53 65 72 e Ser

write to 0x70ce88 [0x5d1bd3] (29 bytes => 29 (0x1D))

0000 - 15 03 01 00 18 c6 b7 50-cd 58 8a 44 27 b5 ce 47 .......P.X.D'..G

0010 - 61 fd 00 94 bd 72 51 05-54 37 0a ff 60 a....rQ.T7..`

write to 0x70ce88 [0x5d1bd3] (29 bytes => 29 (0x1D))

0000 - 15 03 01 00 18 a9 42 59-df 9c 8c 65 6e d2 3a cd ......BY...en.:.

0010 - 62 13 8e b0 73 c0 9d 36-f6 e2 08 ac 82 b...s..6.....

5476:error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number:.\ssl\s3_pkt.c:338:

And that's what WireShark shows for this conversation:

WireShark Windows 2003 SMTP - HELLO

Looks like Windows 2003 SMTP sends some crap ; ) WireShark ignores it but OpenSSL client tries to decrypt and fails.

OpenSSL client then tells server that there was a handshake error - two writes at the end.

 

With RC4-SHA and RC4-MD5 the ciphertext length exceeds the plaintext length by a fixed number of bytes. With DES-CBC3-SHA the ciphertext length exceeds the plaintext length by a variable number of bytes, but both Exchange and MailSite send the packets whose length is plaintext + maximum possible overhead, thus emitting random trailing data from the stack or heap after the first application data record. The servers in question should be removed from active Internet-facing duty. Their software stack is too ancient. Postfix Users - lost connection error, need help debugging

 

I've been told this is a base platform (Windows) issue, but on the other hand: kb 938857 seems to suggest an issue in Exchange itself (fix released more recently than my original information on this subject). The article tries (poorly) to say that unlike stream ciphers (such as RC4), block ciphers in useful modes (i.e. not ECB which is not used for security reasons) require padding for inputs that are not a multiple of the block size and that the required expansion of the input buffer is not handled correctly. NEOHAPSIS - Peace of Mind Through Integrity and Insight

This explains why also AES fails after kb-948963 update. Since both TLS_RSA_WITH_AES_128_CBC_SHA AES128-SHA and TLS_RSA_WITH_AES_256_CBC_SHA AES256-SHA are block cipher suites probably the same issue occurs.

 

And that's why plaintext is not being re-negotiated:

Postfix falls back to plain-text when STARTTLS or the SSL handshake fails, but here, the failure is triggered by garbage after the encrypted EHLO response, which breaks the SSL records containing MAIL FROM:. We don't fallback to plaintext after the mail transaction begins. Postfix Users - lost connection error, need help debugging

To be fair it's not all garbage, just garbage at the end ; )

 

2014/07/29 Update Windows_SMTP_bug_breaks_3DES_and_AES_CBC

That e Ser at the end of SSL packet kept bugging me because it was never changing, so I did some more digging to figure out what is happening exactly.

I took another Windows Server 2003 and found out that now crap at the end is different -

Windows 2003 SMTP sends crap at the end of SSL

Apparently it comes from my server's SSL certificate -

SSL certificate

Amazing ; )

 

I've also found out that by changing SMTP settings on the server I can make it to send some different parts of the certificate -

Windows 2003 SMTP sends crap at the end of SSL - now on the train
SSL certificate - now on the train

Obviously there is a bug in SMTP service.

I have not found a way to force server to send something else by forging packets on the client, however there is a chance that there is vulnerability.

 

After some more searches I've found KB957047 - E-mail messages are blocked after you set the value of the FIPSAlgorithmPolicy registry entry to "1" on a server that is running Exchange Server 2003

Now, when FIPS is enforced 3DES is used, so I've tried the update and it made the issue to go away! Even better - AES started to work too with SMTP.

This hotfix replaces Smtpsvc.dll which has the bug, however ms10-024 Description of the security update for Windows SMTP Service April 13, 2010 and July 13, 2010 contains more recent file, so I installed the hotfix and security update on top of it.

 

So everything is fine with Windows 3DES implementation. The real issue is SMTP service and Exchange IMAP and POP3 services are buggy.

The issue is exaggerated by the fact that mail servers will consider SSL connection successful and won't fallback to non-secure connection and will keep re-trying delivery.

Also probably issue became more apparent after heartbleed paranoia when a lot of OpenSSL installations were upgraded and removed RC4 as not-secure-enough.

 

Conclusion

KB957047 fixes SMTP, KB938857 - Exchange IMAP and POP3, KB948963 adds AES support and both 3DES and AES start to work properly with SMTP service and Exchange server.

It may be necessary to install KB976323 after SMTP hotfix.

R.I.P. Windows Server 2003 ;(

 

References

How to Use Telnet to Test SMTP Communication

Enhanced Status Codes for Delivery - RFC 1893

System Error Codes (1000-1299)

How to Enable regtrace

How to enable Schannel event logging in IIS

How to decrypt an SSL or TLS session by using Wireshark - nettracer - Site Home - TechNet Blogs

Decoding ssl traffic - Wireshark Q&A

SSL cipher settings - For the good of all of us

SSL-TLS Alert Protocol & the Alert Codes - Unleashed - Site Home - MSDN Blogs

Transport Layer Security - Wikipedia, the free encyclopedia

E-mail messages are blocked after you set the value of the FIPSAlgorithmPolicy registry entry to "1" on a server that is running Exchange Server 2003

You cannot use a 3DES-based Secure Sockets Layer (SSL) connection to connect to Exchange 2003

ms10-024 Description of the security update for Windows SMTP Service April 13, 2010 and July 13, 2010

Microsoft Security Bulletin MS10-024 - Important

2014/02/28 setx_GPU_MAX_ALLOC_PERCENT_100_in_the_miner_batch

setx commands(GPU_MAX_ALLOC_PERCENT and others) should not be put into the miner batch file.

2014/01/29 Force_Monitor

How to force display on Windows.

2013/12/21 Proper_CleanUp

Proper Cleanup - How to clean system from AMD driver and re-install them.

2013/01/24 cgminer_2_11_3_x64_portable_10_6_8

cgminer version 2.11.3 compiled on Mac OS X 10.6.8 x64 with libraries included

src

 

& echo "" | gcc -march=native -v -E - 2>&1 | grep cc1

export CC="gcc-4.8"

export CFLAGS="-O3 -pipe -march=core2 -mcx16 -msahf -mno-movbe -mno-aes -mno-pclmul -mno-popcnt -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-bmi2 -mno-tbm -mno-avx -mno-avx2 -mno-sse4.2 -msse4.1 -mno-lzcnt -mno-rtm -mno-hle -mno-rdrnd -mno-f16c -mno-fsgsbase -mno-rdseed -mno-prfchw -mno-adx -mfxsr -mno-xsave -mno-xsaveopt --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=3072 -mtune=core2 -fPIC -mmacosx-version-min=10.6.8"

export CXXFLAGS="${CFLAGS}"

export ARCHFLAGS="-arch x86_64-apple-darwin11.2.0"

./autogen.sh --enable-cpumining --enable-scrypt --build=x86_64-apple-darwin11.2.0

./configure --build=x86_64-apple-darwin11.2.0

make

 

otool -L ./cgminer:

./libcurl.4.dylib (compatibility version 7.0.0, current version 7.0.0)

./libjansson.4.dylib (compatibility version 9.0.0, current version 9.0.0)

/System/Library/Frameworks/OpenCL.framework/Versions/A/OpenCL (compatibility version 1.0.0, current version 1.0.0)

./libncurses.5.4.dylib (compatibility version 5.4.0, current version 5.4.0)

/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 125.2.11)

./libgcc_s.1.dylib (compatibility version 1.0.0, current version 1.0.0)

otool -L ./libcurl.4.dylib:

/usr/local/opt/curl/lib/libcurl.4.dylib (compatibility version 8.0.0, current version 8.0.0)

./libssl.0.9.8.dylib (compatibility version 0.9.8, current version 0.9.8)

./libcrypto.0.9.8.dylib (compatibility version 0.9.8, current version 0.9.8)

/System/Library/Frameworks/LDAP.framework/Versions/A/LDAP (compatibility version 1.0.0, current version 2.2.0)

./libz.1.dylib (compatibility version 1.0.0, current version 1.2.3)

/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 125.2.11)

otool -L ./libssl.0.9.8.dylib:

/usr/lib/libssl.0.9.8.dylib (compatibility version 0.9.8, current version 0.9.8)

./libcrypto.0.9.8.dylib (compatibility version 0.9.8, current version 0.9.8)

/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 125.2.11)

otool -L ./libcrypto.0.9.8.dylib:

/usr/lib/libcrypto.0.9.8.dylib (compatibility version 0.9.8, current version 0.9.8)

/System/Library/PrivateFrameworks/TrustEvaluationAgent.framework/Versions/A/TrustEvaluationAgent (compatibility version 1.0.0, current version 1.0.0)

./libz.1.dylib (compatibility version 1.0.0, current version 1.2.3)

/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 125.2.11)

otool -L ./libz.1.dylib:

/usr/lib/libz.1.dylib (compatibility version 1.0.0, current version 1.2.3)

/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 125.2.0)

otool -L ./libjansson.4.dylib:

/usr/local/lib/libjansson.4.dylib (compatibility version 9.0.0, current version 9.0.0)

/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 125.2.11)

otool -L ./libncurses.5.4.dylib:

/usr/lib/libncurses.5.4.dylib (compatibility version 5.4.0, current version 5.4.0)

/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 125.2.0)

otool -L ./libgcc_s.1.dylib:

/usr/local/Cellar/gcc48/4.8.0/gcc/lib/libgcc_s.1.dylib (compatibility version 1.0.0, current version 1.0.0)

/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 125.2.11)

2013/01/24 C1_22_reference_and_manual

Oscillograph C1-22. Technical reference and instruction manual. / Осциллограф C1-22. Теxническое описание и инструкция по эксплуатации. pdf djvu

2012/08/03 nVidia_9600m_GT_And_Amilo_1667g_3667g

nVidia GeForce 9600m GT DOES work in Fujitsu-Siemens Amilo A1667g / A3667G after flashing modded BIOS by .NetRolller 3D

2011/12/20 HD_4650_MXM_HD_3850_MXM_Amilo_1667g

ATI Radeon HD 4650 MXM II and ATI Radeon HD 3850 MXM III do not work in Fujitsu-Siemens Amilo 1667g((

2011/12/06 Application_failed_codesign_verification

FUCK Apple, there I said it ))

Application failed codesign verification. The signature was invalid, or it was not signed with an Apple submission certificate. (-19011)

No dots in build path or app name are allowed!!!

2011/11/11 PSP_Go_And_DLink_615

Sony PSP Go(802.11b) and laptops(802.11n) through DLink DIR 615 Rev.B2 router

The usual fucks go to Sony, for being Sony and DLink for making crappy routers.

The issue when PSP Go connects to the router all other 802.11n clients are dropped and stuck in endless connect/disconnect loop.

Following router configuration resolves the issue -

Setup->Wireless Settings->Manual Wireless Network Setup->802.11 Mode->Mixed 802.11n, 802.11g and 802.11b

Setup->Wireless Settings->Manual Wireless Network Setup->Channel Width->20 MHz

Setup->Wireless Settings->Manual Wireless Network Setup->WPA Mode->Auto (WPA or WPA2)

Setup->Wireless Settings->Manual Wireless Network Setup->Cipher Type->AES

Advanced->Advanced Wireless->WLAN Partition->check

Advanced->Advanced Wireless->WMM Enable->check

Laptops and other 802.11n/802.11g clients should use WPA2 and AES in their connection settings.

Router current firmware is 2.27RU, current firmware date is 2010/06/17

2011/05/26 WSS_and_System.Web.Security.ActiveDirectoryMembershipProvider

Windows SharePoint Service 3.0 and System.Web.Security.ActiveDirectoryMembershipProvider

Following configuration works fine for http://mydomain.com, configured for Forms Based auth(FBA) and located in Internet zone

<connectionStrings>

<add name="ADConnectionString" connectionString="LDAP://mydomain.com/OU=SharePoint,DC=mydomain,DC=com" />

</connectionStrings>

<membership defaultProvider="UsersFromWeb">

<providers>

<add name="UsersFromWeb"

type="System.Web.Security.ActiveDirectoryMembershipProvider,System.Web,Version=2.0.0.0,

Culture=neutral,PublicKeyToken=b03f5f7f11d50a3a"

connectionStringName="ADConnectionString" enableSearchMethods="true" attributeMapUsername="sAMAccountName" />

</providers>

</membership>

However the same configuration causes the same site, but in Default zone, to hang up while accessing Site collection administrators(_admin/owners.aspx), also People Picker hangs up

Following configuration works

<add name="ADConnectionString" connectionString="LDAP://ip-address-of-mydomain-com/OU=SharePoint,DC=mydomain,DC=com" />

Another day lost for WSS..

P.S. Don't underestimate the power of iisreset <:)

2011/04/13 Fuck_Adobe

Fuck Adobe!

They've supported Flash technology by buying Macromedia, yeah, fuck Flash also and Macromedia (fucking morons created Flash in the first place)

Anyway, Adobe After Effects CS5 work only on 64-bit systems, Photoshop CS5 can run on x86-32 bit systems, but may experience problems.

As there is no 32-bit build of AE CS5 I've tried to install CS4 and experienced some problems.

Obsoletely Fabulous or installing Adobe After Effects CS4 on Windows 2003/XP PC based on AthlonXP+

2011/03/30 Windows_SMB_over_NAT_concurrent_connection_issue

To access Windows XP/2003 SMB share(File and Printer Sharing) concurrently from several computers across NAT(W-Fi router for example) you should fall back to NetBIOS over TCP by either blocking TCP 445 or setting REG_DWORD HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NetBT\Parameters\SmbDeviceEnabled to 0

Some info to read:

Concurrent NetBios (SMB) requests over a NAT Firewall
Analysis of a networking problem: The case of the mysterious SMB connection resets (or "How to not design a network protocol")
You cannot make more than one client connection over a NAT device

2011/03/04 D2NT_Charged_Items_Support

D2NT 3.1 cannot use charged items. Well, actually it can, but it cannot switch to charged item skill.

That's because instead of sending 3c 3c520000000e000000 packet it sends 3c 3c52000000ffffffff(this is packet for MarrowWalk LifeTap)

I've found it using NetStuff plugin for RedVex.

And decided to add packet rewriting functionality to NetStuff.

So, to make D2NT use charged item you need to include following line in your NTConfig.ntl -

Say(".rewrite send add 3c 3c52000000ffffffff 3c520000000e000000");

Only you should replace 52 by your charged item skill number, you can look it up in sdk/skills.txt and convert it to HEX(52 HEX = 82 DEC).

Download modified NetStuff v2.0

Also remember, that using bots or/and RedVex on battle.net will get you ban or rip.. sooner or later))

2011/03/06 Update

Turns out that second byte in the packet represents item id if skill is casted from the item or equals -1 if skill is native to the char.

So in order to correctly rewrite the packet item id is needed, also NTBOT does not repair charged items.

I wrote D2NT script - NTCharged.ntl, which implements missing functionality for some charged items.

I was, however, not able to automatically configure NetStuff to rewrite packets for all charged items, because I've found no way to get charged item skill using D2NT JS API.

But the script could be easily extended to suit any charged item.

Copy the script to D2NT libs/ folder and include it in your character config - Include("libs/NTCharged.ntl");

Script will check if any charged item needs to be repaired(if it has less or equal to 1 charge) and repair it, also script will configure NetStuff to rewrite the packets.

Currently script supports MarrowWalk and Nature's Peace.

2011/03/04 IIS6_NDR_Spam_Attack_Vulnerability"

IIS 6.0 does NOT check if recipient exists by design. Such behaviour makes it vulnerable to NDR spam-attacks.

However, rejection functionality may be implemented using IIS SMTP OnInboundCommand protocol event sink.

Actually it was done a long time ago ;))

5xxsink is designed to do one thing and do it well: to look up full e-mail addresses in a locally stored text file and reject all RCPT TO commands that do match a line in the file. That's it!

2011/01/14 Heroes_of_Might_and_Magic_3_multiplayer_issue

On Windows Vista/7 Heroes 3 requires SSDP Discovery service for TCP/IP multiplayer game.

2010/12/15 DivX_sux

DivX Web Player review or why DivX Web Player suck? :D

2010/12/08 DDOS_PayPal_MasterCard_PostFinance_Support_WikiLeaks

The war has begun! (rock) Support WikiLeaks! ddos/telnet/ping www.postfinance.ch www.mastercard.com www.paypal.com

2011/03/06 Update

I'm banned by PayPal by IP) Only one IP got banned though.

2010/12/08 Doom_3_zForceAmbientLight_Mod

Doom 3 zForceAmbientLight Mod
Doom 3 zForceAmbientLight Mod Readme
Original Doom 3
Doom 3 with white ambient
Doom 3 with red ambient
Doom 3 with green ambient
Doom 3 with blue ambient